bandeau princess

Ressources Denis

J'ai migré le site vers une nouvelle version : les stats sont remis à zéro en Juillet 2017

Message : virtualmin [ERROR] unknown variable 'validate_password_policy=LOW'

lors d'une mise à jour de php 5.6 j'ai eu le message :

virtualmin [ERROR] unknown variable 'validate_password_policy=LOW'

Dans le coup, panique à bord, les sites ne fonctionnent plus :(

j'ai donc employé les grands moyens après sauvegarde des hosts :

sudo apt-get purge mysql-server-5.7

puis un

sudo apt-get install mysql-server-5.7

la machine à moulinée, et mis à jour les bases existantes ...super, ça marche ...Ouf !

09/2018 autre solution :

contexte du probleme, j'ai le message suivant :

your password does not satisfy the current policy requirements

mysql::execute_sql_logged failed : SQL insert into user (host, user, ssl_type, ssl_cipher, x509_issuer, x509_subject, plugin, authentication_string) values ('localhost', 'yourpassword', '', '', '', '', 'mysql_native_password', password('adminpassword')) manqué : Your password does not satisfy the current policy requirements at ../web-lib-funcs.pl line 1493

une partie est importante :

your password does not satisfy the current policy requirements

solution :
> dans le terminal, taper :

mysql -h localhost -u root -p
mysql>uninstall plugin validate_password;

puis relancer le script de sécurisation mysql :
sudo mysql_secure_installation

attention à choisir "low" dans le script.

autre solution pour ce dernier choix :

mysql> SET GLOBAL validate_password_policy=LOW;

source :
https://stackoverflow.com/questions/43094726/your-password-does-not-satisfy-the-current-policy-requirements

Please publish modules in offcanvas position.